CM18 - BCM4301

Tópicos relacionados com o suporte a dispositivos de acesso à Internet.

Moderadores: DarkLord, 7luas

baldeante
Mensagens: 53
Registado: quinta 06 ago 2009, 11:40
Localização: Caldas da Rainha
Contacto:

CM18 - BCM4301

Mensagempor baldeante » sexta 03 ago 2012, 09:42

Boas,

Esta placa wireless esta a dar luta ... lembro-e de ter instalado esta placa no CM16 com dois ou três comandos na linha de comandos e um reboot mas desta vez não acerto ...

Código: Selecionar todos

01:02.0 Network controller: Broadcom Corporation BCM4301 802.11b Wireless LAN Controller (rev 02)


Segundo consigui apurar a forma correcta e instalar estes pacotes e fazer um reboot :

Código: Selecionar todos

sudo apt-get install b43-fwcutter firmware-b43legacy-installer bcmwl*


Já confirmei os modulos estão aparentemente carregados

Código: Selecionar todos

#lsmod |grep b43
b43                   342643  0
mac80211              436455  1 b43
cfg80211              178679  2 b43,mac80211
bcma                   25651  1 b43
ssb                    50691  1 b43


Podem dar-me mais algumas luzes ... o Google não parece estar a ajudar ... eu devia ter feito umas notas quando instalei o CM16 nestas maquinas :x
Imagem

madhatter
Mensagens: 560
Registado: terça 04 ago 2009, 10:06

Re: CM18 - BCM4301

Mensagempor madhatter » sexta 03 ago 2012, 12:36

Se os módulos estão carregados devia funcionar...

Tens os pacotes linux-firmware e linux-firmware-nonfree instalados?

baldeante
Mensagens: 53
Registado: quinta 06 ago 2009, 11:40
Localização: Caldas da Rainha
Contacto:

Re: CM18 - BCM4301

Mensagempor baldeante » sexta 03 ago 2012, 12:52

Sim tenho os pacotes instalados, e exatamente pelo facto de os módulos estarem carregados que me esta a dar a volta a cabeça ...

Neste momento estou a descarregar o CM18 LXDE, o Gnome classic (Sem Efeitos) esta a congelar aleatoriamente acho que mesmo sem efeitos algo esta mal com o vídeo se largo o PC por uns minutos o ecrã pisca e a partir dai só mexe o rato tenho de me ligar por ssh para reiniciar o PC nem o serviço gráfico reinicia ...

O tempo que levei a escrever este texto noutro PC já deu para congelar de novo ...

Acho que o facto de não haver (ou pelo menos eu não encontro) configuração do screensaver no neste modo gráfico provoca alguma pancada quando o tempo de inatividade chega ao valor definido ... estou a ficar farto destas Intel integradas e o seu mau suporte ..
Imagem

baldeante
Mensagens: 53
Registado: quinta 06 ago 2009, 11:40
Localização: Caldas da Rainha
Contacto:

Re: CM18 - BCM4301

Mensagempor baldeante » sexta 03 ago 2012, 14:09

Código: Selecionar todos

01:02.0 Network controller: Intersil Corporation ISL3886 [Prism Javelin/Prism Xbow] (rev 01)


Acabei de encontrar esta placa wireless perdida na gaveta de peças ... e não é que funcionou logo ... agora só falta descobrir o driver para o Windows :evil:

Sei que estou apenas a adiar o problema uma vez que tenho mais umas 5 ou 6 maquinas com placas iguais mas com sorte nessa altura o kernel+modulos do sistema já detectam a placa nativamente ... vamos rezar :mrgreen: :mrgreen:

Vale a pena guardar velharias ...
Imagem

RicardoGaio
Mensagens: 745
Registado: quarta 05 ago 2009, 13:20
Localização: Torres Vedras

Re: CM18 - BCM4301

Mensagempor RicardoGaio » sexta 03 ago 2012, 15:54

Vê lá se te ajuda:
albertino Escreveu:No terminal.

sudo apt-get install firmware-b43-installer.

Reinicio o sistema e já está.


Retirado daqui: viewtopic.php?t=87203.

Comigo funcionou 5* em CM17 64bits.
Um abraço, Ricardo
Imagem

baldeante
Mensagens: 53
Registado: quinta 06 ago 2009, 11:40
Localização: Caldas da Rainha
Contacto:

Re: CM18 - BCM4301

Mensagempor baldeante » segunda 06 ago 2012, 12:13

Já tentei o comando que referes por acaso também já tinha andado a ver o tópico que referes no link .... estou a utilizar a versão 32bits .. se calhar e por isso .... mas se for é estranho ...
Imagem


Voltar para “Suporte a hardware”

Quem está ligado:

Utilizadores neste fórum: Nenhum utilizador registado e 2 visitantes