Não consigo ligar à net Não, não é da ligação)

Tópicos relacionados com a configuração dos diversos tipos de ligação à Internet.

Moderadores: DarkLord, 7luas

rui.o.pereira
Mensagens: 4
Registado: sábado 04 fev 2012, 19:16

Não consigo ligar à net Não, não é da ligação)

Mensagempor rui.o.pereira » sábado 08 nov 2014, 14:06

Viva,

Preciso da vossa ajuda.

Quando instalei o linux CM15 KDE, (é um portátil velho) tinha net e trabalhava muito bem.

Depois instalei o compilador (gcc) de C (apt-get install KDEvelop) ou foi pelo synaptic (honestamente já não me lembro...)

Bem como o apache, mysql e o php (agora falta-me o módulo do apache para php (apache2php ) )

Uns foi pelo apt-get, outros, foi pelo synaptic.

(teria sido mais facil, instalar o LAMP ou o xampp, mas não os encontrei.)

Queria fazer uma experiência com sockets (pipes) no linux CM15. com 2 programas em C (cliente.c e servidor.c) para os meus alunos de programação verem.

E também outras actualizações ...(já n me lembro quais...)

Agora não consigo ligar à net (nem por fio nem por wireless, máquina tem 2 IP(s) (uma placa de rede RJ-45 e outra wireless) e não liga com nenhum, tanto por DHCP como forçando os IP(s) e pondo o ip do gateway.
(tinha dívida se fosse ligação WEP ou WPA, mas já vi isso, é WPA pessoal)

Não, não é da ligação tenho um windows 7 de 64 bits ao lado que funciona bem, tanto por fio como por wireless).

Confesso que fiz uma "brincadeira" sendo uma máquina velha alterei o /etc/inittab e meti o init, por defeito a 3 mas já voltei a pôr 5. (pois queria apenas compilar o em modo caractere os meus: cliente.c e o meu servidor.c) no windows: isto n compila....por causa da biblioteca do socket.

o loopback funciona, pois o apache dele responde no firefox a: http://localhost e até ao seu prórpio IP (http://192.168.10.4) e por estranho que pareça, tenho um apache no windows (este também tem 2 IPs): "http://192.168.10.4" (wireless) e http://192.168.10.8 (com fio ) e o meu caixa mágica também se liga bem a eles, sem problemas..

Terá a ver com o firefox ? Não consigo abrir a pagina do google.pt, tudo o que é externo, esqueçam não dá, interno (da máquina windows ao lado) trabalha tudo bem, mas um ping sapo.pt não trabalha...


Desculpem a confusão, mas queria preparar uma aula de sockets para ensinar 2 processos a comunicar por um tubo...E tb precisava de ir à net bucar o módulo apache2php e adicioná-lo no httpd.conf do apache.


Alguém me pode dar uma "luz"? (já tive net e deixei de ter e não sei porquê)

Alguém me pode indicar indicar um comando que faça a verificação da ligação? (ja executei o fsck, como root).
Última edição por rui.o.pereira em sábado 08 nov 2014, 18:37, editado 1 vez no total.

rui.o.pereira
Mensagens: 4
Registado: sábado 04 fev 2012, 19:16

Re: Não consigo ligar à net Não, não é da ligação)

Mensagempor rui.o.pereira » sábado 08 nov 2014, 18:35

Já consegui, tinha o dhcp mal

...desculpem...


(no windows, tanto faz...Mas aqui tenho de pôr a máquina a receber um ip dinamico --- DHCP ligado)


Voltar para “Configuração”

Quem está ligado:

Utilizadores neste fórum: Nenhum utilizador registado e 1 visitante