Amarok "crasha" (enviado por marioliveira)

Tópicos colocados na versão anterior da Comunidade Caixa Mágica. É possível pesquisar questões já colocadas neste fórum, mas não é possível criar novos tópicos ou editar / responder a tópicos já existentes.

Moderadores: DarkLord, 7luas

bofh
Site Admin
Mensagens: 3
Registado: terça 09 jun 2009, 17:44

Amarok "crasha" (enviado por marioliveira)

Mensagempor bofh » segunda 03 ago 2009, 17:20

Desde que instalei o CM ainda não tinha usado o amarok. Entretanto, como vi uma actualização no synaptic, fi-la, e de seguida fui espreitar o amarok pela 1ª vez. Azar! Estoirou.
Guardei um dump do crash, mas talvez alguém tenha tido esse problema e me possa dizer como por o amarok de pé. Obrigado


++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Enviado por: madhatter

Titulo: Qual a versão que tens instalada?

Podes ver isso com o seguinte comando na linha de comandos:
rpm -qa | grep -i amarok

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Enviado por: marioliveira

Titulo: versão do amarok

O resultado do comando é amarok-1.3.2-1

Já agora, o k3b está nas mesmas condições, isto é, antes de o ter actualizado funcionava (por acaso, vi que sim) e agora "kaput". Executei o mesmo comando para k3b e a resposta é:
k3b-mad-0.12.5-3.0
k3b-0.12.5-3.0


++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Enviado por: madhatter

Titulo: Primeiro que tudo:

Leste isto certo:
<a href="ftp://ftp.caixamagica.pt/10/contribuicoes/LEIA-ME" target=_blank>ftp://ftp.caixamagica.pt/10/contribuicoes/LEIA-ME</a>

é que essas versões que tens instaladas parecem-me ter sido instaladas a partir do site de contribuições... logo por vezes és capaz de ter surpresas dessas...

Agora para teres o amarok e o k3b a rebentar, e sendo ambos versões bastante recentes provavelmente deves ter aí algum pacote de alguma biblioteca que devias também ter actualizado e não actualizaste...

Se abrires o Synaptic ele não te reclama de nenhuma dependência quebrada?


De qualquer forma a melhor maneira de saber o que está a acontecer é correr o amaroK ou o K3B a partir de uma consola... Ou seja, no KDE clica no simbolo da consola na barra de programas e depois escreve:
amarok

e carrega em enter... e depois vê se aparece algum erro na consola...

e para o k3b escreve:
k3b

e verifica o mesmo....

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Enviado por: marioliveira

Titulo: Dificuldades no amarok e k3b

Quando faço isso, leio:
amarok: [Loader] Don+`t run gdb, valgrind, etc. against this binary! Use amarokapp
KCrash: Application `amarokapp` crashing
(se digitar o commando `amarokapp` leio só a última linha)

Ao digitar o comando k3b, obtenho:
k3b: (K3bExternalBinManager) Cdrecord 2.1 features: gracetime, overburn, cdtext, clone, tao, cuefile, xamix, plain-atapi, hacked-atapi
k3b: (K3bExternalBinManager) 2 1 -1 seems to be cdrecord version >= 1.11a02, using burnfree instead of burnproof
k3b: (K3bExternalBinManager) seems to be cdrecord version >= 1.11a31, support for Just Link via burnfree driveroption
k3b: (K3bDevice::HalConnection) initializing HAL 0.4
KCrash: Application `k3b` crashing...

Isto e o que informaste acerca do site de contribuições, e independentemente do problema em si, suscita-me várias questões:
- Como posso saber de onde (de qual repositório) estou a fazer as instalações ou actualizações?
- Caso algo corra mal, como correu, há alguma maneira de regressar às versões funcionais da aplicação? Como?

Talvez eu esteja a perguntar coisas que já foram respondidas algures. Se assim é, desculpa e diz-me onde ler o que houver sobre o assunto, porque sinceramente não fiz até agora nenhuma pesquisa sobre este tema.
Independentemente disto, se puderes dar uma ajuda quanto ao ressuscitar daqueles programas... :-)


++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Enviado por: marioliveira

Titulo: Dificuldades no amarok e k3b (cont)

Desculpa, esqueci-me de responder à tua outra pergunta:

Não, o synaptic não acusa nenhum pacote quebrado, nem nenhuma anomalia.

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Enviado por: marioliveira

Titulo: Resolvido

Pronto, estão ambos a funcionar. Vou dizer o que fiz, e peço me corrijam se o raciocínio estiver errado algures:

Primeiro, adicionei o CD do CM10 como repositório (ainda não tinha feito isso)
Depois, deixei assinalado como repositório apenas o CD, desactivando os outros, o que, segundo pensei, iria fazer com que a leiturade programas a instalar fosse feita apenas do CD
De seguida, desinstalei completamente quer o K3B, quer o amarok.
Actualizei a leitura de pacotes do Synaptic (lendo apenas os do CD).
Instalei, após esta actualização, o k3b, que funcionou quando o executei a seguir. Instalei, de igual modo o amarok, que também funcionou à primeira (tanto quanto pude entrever, é uma versão anterior àquela que eu tinha actualizado anteriormente. Mas, que diabo, funciona.

Remarquei como repositórios do Synaptic os sites do CM, e aproveitei para desmarcar o das contribuições, para evitar problemas semelhantes com outra aplicação qualquer. Penso (e alguém me corrija se estiver errado) que,depois de desactivar este repositório e de ter feito nova actualização dos pacotes, os que poderiam ser lidos no site de contribuições desaparaceram da lista de pacotes disponíveis, certo ou não?

Voltar para “Mensagens arquivadas”

Quem está ligado:

Utilizadores neste fórum: Google [Bot] e 1 visitante